Opened 9 years ago

Closed 9 years ago

#1398 closed defect (fixed)

compile error under cygwin with rev 4200

Reported by: cybero2912 Owned by:
Priority: blocker Component: General
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

4200

Issue Description

[ 23%] Building C object CMakeFiles/csoscam.dir/oscam-config.o
/home/cybero/oscam-svn/oscam-config.c: In function 'write_config':
/home/cybero/oscam-svn/oscam-config.c:2175: error: 'struct s_config' has no memb
er named 'cc_reshare_service'
make[2]: * [CMakeFiles/csoscam.dir/oscam-config.o] Error 1
make[1]:
* [CMakeFiles/csoscam.dir/all] Error 2
make: * [all] Error 2

When the issue occurs

when compiling

How the issue is reproducable

always

Change History (4)

comment:1 Changed 9 years ago by cybero2912

tried to compile 4199 - works fine !

comment:2 Changed 9 years ago by Cccamland

yes i now but 4200 & 4201 this message apears

comment:3 Changed 9 years ago by alborland

oscam-config.c:

fprintf_conf(f, CONFVARWIDTH, "reshare_mode", "%d\n", cfg->cc_reshare_service);

edit to:

fprintf_conf(f, CONFVARWIDTH, "reshare_mode", "%d\n", cfg->cc_reshare_services);

than working!
its a typo

comment:4 Changed 9 years ago by Deas

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.