Opened 9 years ago

Closed 8 years ago

#1635 closed defect (wontfix)

r ERROR in IO_Serial_Write u=-1 to_send=5 errno=11

Reported by: kero Owned by:
Priority: blocker Component: Reader
Severity: high Keywords: reader error
Cc: Sensitive: yes

Description

Revision

ppc oscam_1.00 4066

Issue Description

ppc oscam_1.00 4066
r ERROR in IO_Serial_Write u=-1 to_send=5 errno=11

When the issue occurs

2011/02/10 1:38:17 30016270 s newcamd: initialized (fd=7, port=9998, crypted)
2011/02/10 1:38:17 30016270 s CAID: 0D00
2011/02/10 1:38:17 30016270 s provid #0: 0000C0
2011/02/10 1:38:17 30016270 s provid #1: 0000C4
2011/02/10 1:38:17 30016270 s provid #2: 0000C8
2011/02/10 1:38:17 30016270 s provid #3: 0000CC
2011/02/10 1:38:17 30016270 s cccam: initialized (fd=8, port=9999, crypted)
2011/02/10 1:38:17 30016270 s radegast: disabled
2011/02/10 1:38:17 30016270 s http thread started
2011/02/10 1:38:17 30016270 s creating thread for device /dev/sci0 slot 0
2011/02/10 1:38:17 30016270 s waiting for local card init
2011/02/10 1:38:17 30859B50 h HTTP Server listening on port 3333
2011/02/10 1:38:17 31059B50 r reader thread started (thread=31059B50, label=reader44, device=/dev/sci0, detect=cd, mhz=500, cardmhz=600)
2011/02/10 1:38:17 31059B50 r IFD: Opening device /dev/sci0

2011/02/10 1:38:17 31059B50 r IFD: Device /dev/sci0 succesfully opened

2011/02/10 1:38:17 31059B50 r ct_init on /dev/sci0: 1
2011/02/10 1:38:17 31059B50 r reader44 card detected
2011/02/10 1:38:17 31059B50 r IFD: Activating card in reader reader44

2011/02/10 1:38:17 31059B50 r IFD: Activating card
2011/02/10 1:38:17 31059B50 r Extra delay for PPC box between reset and IO_Serial_Read for the ATR
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 3B
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 78
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 12
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 00
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 00
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 54
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 C4
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 03
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 00
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 8F
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 F1
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 90
2011/02/10 1:38:17 31059B50 r IO: Receiving:
2011/02/10 1:38:17 31059B50 00
2011/02/10 1:38:18 31059B50 r TIMEOUT in IO_Serial_WaitToRead
2011/02/10 1:38:18 31059B50 r IO: Receiving:
2011/02/10 1:38:18 31059B50 r TIMEOUT in IO_Serial_Read
2011/02/10 1:38:18 31059B50 r TA1 = 12
2011/02/10 1:38:18 31059B50 r FI = 01
2011/02/10 1:38:18 31059B50 r ATR: 3B 78 12 00 00 54 C4 03 00 8F F1 90 00
2011/02/10 1:38:18 31059B50 r TA1=12 TB1=00 TC1=00 no TD1 means T0
2011/02/10 1:38:18 31059B50 r 1 protocol types detected. Historical bytes: 54 C4 03 00 8F F1 90 00
2011/02/10 1:38:18 31059B50 r No PTS happened, selected protocol T0, F=372, D=2.000000, N=0

2011/02/10 1:38:18 31059B50 r Setting timings: timeout=1198 ms, block_delay=0 ms, char_delay=0 ms
2011/02/10 1:38:18 31059B50 r Protocol: T=0: WWT=9600, Clockrate=6000000

2011/02/10 1:38:19 31059B50 r TIMEOUT in IO_Serial_WaitToRead
2011/02/10 1:38:19 31059B50 r IO: Receiving:
2011/02/10 1:38:19 31059B50 r TIMEOUT in IO_Serial_Read
2011/02/10 1:38:19 31059B50 r Setting T=0 fs=5 mhz ETU=372 WWT=9600 CWT=0 BWT=0 EGT=0 clock=0 check=0 P=0 I=25 U=0
2011/02/10 1:38:19 31059B50 r Maximum frequency for this card is formally 5 Mhz, clocking it to 5.00 Mhz
2011/02/10 1:38:19 31059B50 r IFD: Card in reader reader44 succesfully activated

2011/02/10 1:38:20 31059B50 r [cryptoworks-reader] card detected
2011/02/10 1:38:20 31059B50 r [cryptoworks-reader] type: CryptoWorks?
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 C0 00 00 11
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 C0 00 00 11
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 C0 00 00 11
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 C0
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 C0
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0F 05 04 00 09 3F 02 01 00 F0 00 00 03 00 00
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0F 05 04 00 09 3F 02 01 00 F0 00 00 03 00 00
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0F 05 04 00 09 3F 02 01 00 F0 00 00 03 00 00
2011/02/10 1:38:20 31059B50 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 A4 00 00 02 3F 20
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 A4 00 00 02
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 A4 00 00 02
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 A4
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 A4
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 3F 20
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 3F 20
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 94
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 94
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 02
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 02
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 94 02
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 00 00 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 00 00 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 00 00 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 00 02 EF 11 C2 00 00 00 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 00 02 EF 11 C2 00 00 00 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0A 00 02 EF 11 C2 00 00 00 00 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 00 06 EF 20 C2 00 00 0A 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 00 06 EF 20 C2 00 00 0A 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0A 00 06 EF 20 C2 00 00 0A 00 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 01 AA EF 02 08 00 01 D2 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 01 AA EF 02 08 00 01 D2 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0A 01 AA EF 02 08 00 01 D2 00 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 00 03 EF 03 F8 00 03 7C 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 00 03 EF 03 F8 00 03 7C 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0A 00 03 EF 03 F8 00 03 7C 00 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 00 7E EF 01 F8 00 03 7F 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 00 7E EF 01 F8 00 03 7F 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0A 00 7E EF 01 F8 00 03 7F 00 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C0 F1 09 00 6A 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C0 F1 09 00 6A 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C0 F1 09 00 6A 00 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C4 F1 09 00 C4 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C4 F1 09 00 C4 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 90
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 00
2011/02/10 1:38:20 31059B50 r answer from cardreader reader44:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C4 F1 09 00 C4 00 00 90 00
2011/02/10 1:38:20 31059B50 r write to cardreader reader44:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IO: Sending:
2011/02/10 1:38:20 31059B50 A4 B8 FF FF 0C
2011/02/10 1:38:20 31059B50 r IFD Transmit succesful
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 B8
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C8 F1 09 01 1E 00 00
2011/02/10 1:38:20 31059B50 r IFD Received:
2011/02/10 1:38:20 31059B50 DF 0A 00 0A DF C8 F1 09 01 1E 00 00
2011/02/10 1:38:20 31059B50 r IO: Receiving:
2011/02/10 1:38:20 31059B50 90

How the issue is reproducable

<Please fill in>

<Don't forget to ATTACH (not post here) a log file of oscam in debug mode (start oscam with -d255)!>

Attachments (2)

oscam_reader.log (340.4 KB) - added by kero 9 years ago.
log oscamreader 0d00
oscam_reader2.log (222.3 KB) - added by kero 9 years ago.
oscam reader2 log

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by kero

Attachment: oscam_reader.log added

log oscamreader 0d00

Changed 9 years ago by kero

Attachment: oscam_reader2.log added

oscam reader2 log

comment:1 Changed 8 years ago by docmarius

This issue is old.
We have a new stable version and a new trunk.
Check on current versions and create new ticket if needed.

Last edited 8 years ago by docmarius (previous) (diff)

comment:2 Changed 8 years ago by docmarius

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.