Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1639 closed defect (invalid)

compilation error MAC OSX

Reported by: sacaman Owned by: sacaman
Priority: blocker Component: ! Please select...
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

#4709

Issue Description

Compilation error relative to Gbox Module

When the issue occurs

###################
[ 9%] Building C object CMakeFiles/csmodules.dir/module-dvbapi.o
[ 11%] Building C object CMakeFiles/csmodules.dir/module-gbox.o
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_encrypt_stage1’:
/Users/sacaman/oscam-svn/module-gbox.c:91: warning: unused parameter ‘l’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_encrypt_stage2’:
/Users/sacaman/oscam-svn/module-gbox.c:110: warning: unused parameter ‘l’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_decrypt_stage1’:
/Users/sacaman/oscam-svn/module-gbox.c:130: warning: unused parameter ‘l’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_decrypt_stage2’:
/Users/sacaman/oscam-svn/module-gbox.c:149: warning: unused parameter ‘l’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_compress’:
/Users/sacaman/oscam-svn/module-gbox.c:202: warning: unused parameter ‘gbox’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_decompress’:
/Users/sacaman/oscam-svn/module-gbox.c:228: warning: unused parameter ‘gbox’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_wait_for_response’:
/Users/sacaman/oscam-svn/module-gbox.c:273: warning: implicit declaration of function ‘sem_timedwait’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_send_boxinfo’:
/Users/sacaman/oscam-svn/module-gbox.c:317: warning: implicit declaration of function ‘strnlen’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_send_dcw’:
/Users/sacaman/oscam-svn/module-gbox.c:549: warning: unused parameter ‘cli’
/Users/sacaman/oscam-svn/module-gbox.c:549: warning: unused parameter ‘er’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_send_ecm’:
/Users/sacaman/oscam-svn/module-gbox.c:679: warning: unused parameter ‘buf’
/Users/sacaman/oscam-svn/module-gbox.c: In function ‘gbox_send_emm’:
/Users/sacaman/oscam-svn/module-gbox.c:776: warning: unused parameter ‘ep’
[ 12%] Building C object CMakeFiles/csmodules.dir/module-monitor.o

###################
###################
[ 97%] Built target svnversion
Scanning dependencies of target oscam
[ 98%] Building C object CMakeFiles/oscam.dir/oscam.o
Linking C executable oscam
ld: warning: option -s is obsolete and being ignored
Undefined symbols:

"_strnlen", referenced from:

_gbox_send_hello in libcsmodules.a(module-gbox.o)
_gbox_client_init in libcsmodules.a(module-gbox.o)
_gbox_client_init in libcsmodules.a(module-gbox.o)
_gbox_recv in libcsmodules.a(module-gbox.o)

"_sem_timedwait", referenced from:

_gbox_wait_for_response in libcsmodules.a(module-gbox.o)

ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: * [oscam] Error 1
make[1]:
* [CMakeFiles/oscam.dir/all] Error 2
make: * [all] Error 2

How the issue is reproducable

when i am trying to compile

<Don't forget to ATTACH (not post here) a log file of oscam in debug mode (start oscam with -d255)!>

Change History (6)

comment:1 Changed 9 years ago by Deas

Resolution: invalid
Status: newclosed

don´t post tickets for gbox module! this module is NOT finished now and so this implementation is experimental at the moment.

comment:2 in reply to:  1 Changed 9 years ago by sacaman

Replying to Deas:

don´t post tickets for gbox module! this module is NOT finished now and so this implementation is experimental at the moment.

but i can't compile any more
how i can ignore the gbox module in compilation

thanks

comment:3 Changed 9 years ago by pantgr

go on oscam-svn folder and type ./config.sh select your modules and compile

comment:4 Changed 9 years ago by sacaman

please
how i can compile without the Gbox module there are any way to tell to the compilator to ignore this module like this

cmake -DWEBIF=1 -gbox=0 ..

it's blocking the compilation

comment:5 Changed 9 years ago by luckysquid

hi
I have this problem. can it disable gbox?
thanks

comment:6 Changed 9 years ago by Deas

can you read? don´t think so...

THIS IS NOT A SUPPORT FORUM!!! THIS IS A TROUBLE TICKET SYSTEM!

Note: See TracTickets for help on using tickets.