Opened 9 years ago

Closed 9 years ago

#1856 closed defect (fixed)

rev 5226 compile error on x86

Reported by: littlejoe Owned by: schlocke
Priority: blocker Component: General
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

5226

Issue Description

x86 compile error:
gcc -O2 -DOS_LINUX -DCS_CONFDIR='"/usr/local/etc"' -DWITH_LIBCRYPTO -pthread -Winline -Wall -Wextra -D'CS_SVN_VERSION="5226"' -c icc_async.c
icc_async.c: In function 'ICC_Async_Device_Init':
icc_async.c:135: error: incompatible types in initialization
icc_async.c:147: warning: implicit declaration of function 'll_iter_release'
make[2]: * lib/libcsctapi-x86_64-pc-linux.a(icc_async.o) Error 1
make[1]:
* [prepare] Error 2
make: [i386-pc-linux] Error 2 (ignored)

When the issue occurs

with libcrypto

How the issue is reproducable

<Please fill in>

<Don't forget to ATTACH (not post here) a log file of oscam in debug mode (start oscam with -d255)!>

Change History (6)

comment:1 Changed 9 years ago by imperia

[ 64%] Building C object csctapi/CMakeFiles/csctapi.dir/icc_async.o
/home/imperia/oscam/oscam-svn/csctapi/icc_async.c: In function ‘ICC_Async_Device_Init’:
/home/imperia/oscam/oscam-svn/csctapi/icc_async.c:135:19: error: incompatible types when initializing type ‘struct LL_ITER *’ using type ‘LL_ITER’
make[2]: *** [csctapi/CMakeFiles/csctapi.dir/icc_async.o] Error 1
make[1]: *** [csctapi/CMakeFiles/csctapi.dir/all] Error 2
make: *** [all] Error 2

comment:2 Changed 9 years ago by today

Same error on PPC.

comment:3 Changed 9 years ago by Vlado Fogo

and the same on dockstar *.arm

comment:4 Changed 9 years ago by basta

mipsel too

comment:5 Changed 9 years ago by Deas

please no more "me too" posts. that does not fix it earlier...

comment:6 Changed 9 years ago by Deas

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.