Opened 8 years ago

Closed 8 years ago

#1895 closed defect (invalid)

Software caused connection abort

Reported by: cece Owned by:
Priority: major Component: Reader
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision 5316

2011/05/29 20:42:35 B6EE5B70 p connecting to xxxx.mx.com
2011/05/29 20:42:35 B6EE5B70 p already connected!
2011/05/29 20:42:35 B6EE5B70 p skyit server blocked connection!


2011/05/29 20:44:56 B6EE5B70 p connecting to xxxx.mx.com
2011/05/29 20:44:56 B6EE5B70 p connect(fd=17) failed: (errno=103 Software caused connection abort)
2011/05/29 20:44:56 B6EE5B70 p skyit network connect error!

My oscam is configure as CCcam server.

After while the C lines readers being stuck.

Change History (6)

comment:1 Changed 8 years ago by Admin

"errno=103 Software caused connection abort" can happen if OSCam trys to connect using a SYN packet and then immediately gets a RST packet from the server (instead of a SYN or SYN+ACK). Seems to me like the server is blocking access (perhaps a firewall)...I don't think that this is fiaxable on OSCam side.

comment:2 Changed 8 years ago by cece

Admin, thank you for your replay, but it strange when I restart my oscam then it works well, maybe the other side is using fail2ban script, and blocks me ?

I must restart the oscam to get connected to the C line.

comment:3 Changed 8 years ago by Kayvan

I had the same problem with rev:5320. the problem occurred after a reader restarting.
I revert back to rev:5292

Last edited 8 years ago by Kayvan (previous) (diff)

comment:4 Changed 8 years ago by cece

Yes seems the problem is with cccam reader.

I revert back to 5292 and I will see what will happen.

comment:5 Changed 8 years ago by cece

Same problem with revision 5292

comment:6 Changed 8 years ago by pooyair

Resolution: invalid
Status: newclosed

This comes from Failban or any blocking in your server sides...

Note: See TracTickets for help on using tickets.