Opened 8 years ago

Closed 8 years ago

#1899 closed defect (fixed)

OScam stops on AZBox since 5299

Reported by: pmanu Owned by:
Priority: major Component: DVBApi
Severity: medium Keywords:
Cc: Sensitive: no

Description

Revision

since 5299

Issue Description

Since 5299, oscam stops on AZBox with dvbapi enabled.
This problem does not occur when dvbapi is disabled.

When the issue occurs

  • dvbapi=0 and oscam >= 5299
  • dvbapi=1 and oscam <= 5298

How the issue is reproducable

dvbapi=1 and oscam >= 5299

Attachments (2)

oscam-nodvbapi.log (2.7 KB) - added by pmanu 8 years ago.
oscam-dvbapi.log (5.1 KB) - added by pmanu 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by pmanu

Attachment: oscam-nodvbapi.log added

Changed 8 years ago by pmanu

Attachment: oscam-dvbapi.log added

comment:1 Changed 8 years ago by pmanu

DVBAPI = 0
AZBox[oscamCAS]$ /EMU/OpenXCAS/oscamCAS/oscam-1.00-trunk-svn5343-azbox-mips -d 255 -c /EMU/OpenXCAS/oscamCAS/
[OPENXCAS_API:Wed Jun 1 07:45:47.615] load_xcas_control:98 ## loaded controller ID = 0x19760507
[OPENXCAS_API:Wed Jun 1 07:45:47.641] openxcas_open_with_smartcard:331 ## oscamCAS
[OPENXCAS_API:Wed Jun 1 07:45:47.661] openxcas_create_channel:34 ## (oscamCAS)
[OPENXCAS_API:Wed Jun 1 07:45:47.697] openxcas_module_open_channel:86 ## (oscamCAS)
osdep_msq_server_open : key_request 0x62C4B094 key_response 0x62C4B095
osdep_msq_server_open : request msq is already created
osdep_msq_server_open : response msq is already created
[OPENXCAS_API:Wed Jun 1 07:45:47.800] openxcas_adaptor_open_channel:221 ## (oscamCAS)
osdep_msq_client_connect : key_request 0x62C4B094 key_response 0x62C4B095

DVBAPI = 1
AZBox[oscamCAS]$ /EMU/OpenXCAS/oscamCAS/oscam-1.00-trunk-svn5343-azbox-mips -d 255 -c /EMU/OpenXCAS/oscamCAS/
[OPENXCAS_API:Wed Jun 1 07:47:31.749] load_xcas_control:98 ## loaded controller ID = 0x19760507
[OPENXCAS_API:Wed Jun 1 07:47:31.785] openxcas_open_with_smartcard:331 ## oscamCAS
[OPENXCAS_API:Wed Jun 1 07:47:31.813] openxcas_create_channel:34 ## (oscamCAS)
[OPENXCAS_API:Wed Jun 1 07:47:31.841] openxcas_module_open_channel:86 ## (oscamCAS)
osdep_msq_server_open : key_request 0x62C4B094 key_response 0x62C4B095
osdep_msq_server_open : request msq is already created
osdep_msq_server_open : response msq is already created
[OPENXCAS_API:Wed Jun 1 07:47:31.898] openxcas_adaptor_open_channel:221 ## (oscamCAS)
osdep_msq_client_connect : key_request 0x62C4B094 key_response 0x62C4B095
[OPENXCAS_API:Wed Jun 1 07:47:32.647] openxcas_module_send_msg:179 ## (oscamCAS): success to send message(200) at tryCount = 0
[OPENXCAS_API:Wed Jun 1 07:47:32.654] openxcas_module_send_msg:179 ## (oscamCAS): success to send message(402) at tryCount = 0
AZBox[oscamCAS]$

comment:2 Changed 8 years ago by pmanu

Reversing changeset 5299 for trunk/module-dvbapi.c solves the issue.

comment:3 Changed 8 years ago by Admin

Resolution: fixed
Status: newclosed

Should be fixed in [5344].

comment:4 Changed 8 years ago by john_28

Resolution: fixed
Status: closedreopened

still exists . oscam not crashed but black screen , also stapi users confirm it in the forum ...

comment:5 Changed 8 years ago by john_28

Resolution: fixed
Status: reopenedclosed

since i reproduced this bug with my stapi. now with latest _network lib 5273 , it works very well, so it should be fixed for stapi too ...
Thanks to _network

Last edited 8 years ago by john_28 (previous) (diff)
Note: See TracTickets for help on using tickets.