Opened 9 years ago

Closed 9 years ago

#1913 closed defect (duplicate)

Compile error

Reported by: unixer Owned by:
Priority: critical Component: DVBApi
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

trunk 5361

Issue Description

when compile with module DVB-API

When the issue occurs

tuxbox@HTPCServer:~/oscam-trunk/build_dir$ make
Scanning dependencies of target csmodules
[ 1%] Building C object CMakeFiles/csmodules.dir/module-coolapi.o
[ 2%] Building C object CMakeFiles/csmodules.dir/module-camd35.o
[ 4%] Building C object CMakeFiles/csmodules.dir/module-serial.o
[ 5%] Building C object CMakeFiles/csmodules.dir/module-constcw.o
[ 6%] Building C object CMakeFiles/csmodules.dir/module-newcamd.o
[ 8%] Building C object CMakeFiles/csmodules.dir/module-cccam.o
[ 9%] Building C object CMakeFiles/csmodules.dir/module-stat.o
[ 10%] Building C object CMakeFiles/csmodules.dir/module-radegast.o
[ 12%] Building C object CMakeFiles/csmodules.dir/module-monitor.o
[ 13%] Building C object CMakeFiles/csmodules.dir/module-gbox.o
[ 14%] Building C object CMakeFiles/csmodules.dir/module-dvbapi.o
/home/tuxbox/oscam-trunk/module-dvbapi.c: In function âdvbapi_main_localâ:
/home/tuxbox/oscam-trunk/module-dvbapi.c:1664: warning: implicit declaration of function âpthread_mutexattr_settypeâ
/home/tuxbox/oscam-trunk/module-dvbapi.c:1664: error: âPTHREAD_MUTEX_RECURSIVEâ undeclared (first use in this function)
/home/tuxbox/oscam-trunk/module-dvbapi.c:1664: error: (Each undeclared identifier is reported only once
/home/tuxbox/oscam-trunk/module-dvbapi.c:1664: error: for each function it appears in.)
/home/tuxbox/oscam-trunk/module-dvbapi.c:1669: error: âF_SETSIGâ undeclared (first use in this function)
/home/tuxbox/oscam-trunk/module-dvbapi.c:1670: error: âF_NOTIFYâ undeclared (first use in this function)
/home/tuxbox/oscam-trunk/module-dvbapi.c:1670: error: âDN_MODIFYâ undeclared (first use in this function)
/home/tuxbox/oscam-trunk/module-dvbapi.c:1670: error: âDN_CREATEâ undeclared (first use in this function)
/home/tuxbox/oscam-trunk/module-dvbapi.c:1670: error: âDN_DELETEâ undeclared (first use in this function)
/home/tuxbox/oscam-trunk/module-dvbapi.c:1670: error: âDN_MULTISHOTâ undeclared (first use in this function)
make[2]: * [CMakeFiles/csmodules.dir/module-dvbapi.o] Errore 1
make[1]:
* [CMakeFiles/csmodules.dir/all] Errore 2
make: * [all] Errore 2

How the issue is reproducable

<Please fill in>

<Don't forget to ATTACH (not post here) a log file of oscam in debug mode (start oscam with -d255)!>

Change History (1)

comment:1 Changed 9 years ago by pooyair

Resolution: duplicate
Status: newclosed

with 1912 , as u can see

Note: See TracTickets for help on using tickets.