Opened 8 years ago

Closed 8 years ago

#1968 closed defect (fixed)

freebsd error

Reported by: ruggeroquargentan1 Owned by:
Priority: blocker Component: Reader
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

<any>

Issue Description

<incorrect procedure swap_lb>

When the issue occurs

< when compiling for freebsd and have nds card>

How the issue is reproducable

<freebsd system with nds card>

the error is in reader-videoguard-common.c

procedure swap_lb has a conditional compile :

if BYTE_ORDER != BIG_ENDIAN
return;

in freebsd the return is not executed .

is wrong also the procedure CCamCryptVG_SetSeed
the problem is the same.

thank you .

Attachments (3)

endian.h (4.1 KB) - added by ruggeroquargentan1 8 years ago.
endian.h freebsd 8.1
freebsd.patch (1.3 KB) - added by Admin 8 years ago.
Please check if the attached patch fixes your problem.
freebsd2.patch (1.4 KB) - added by Admin 8 years ago.
Could also be that you need this one (sorry can't try myself as I don't have a Freebsd system)

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by ruggeroquargentan1

Priority: Please fill inblocker
Severity: Please fill inhigh

comment:2 Changed 8 years ago by Admin

I don't understand the problem. The function is correct because swapping bytes is only necessary on Big Endian machines. Or does Freebsd not correctly define the byte order parameters?
Edit: Can you attach your /usr/include/machine/endian.h (or wherever your include folder is with the endian.h)?

Last edited 8 years ago by Admin (previous) (diff)

Changed 8 years ago by ruggeroquargentan1

Attachment: endian.h added

endian.h freebsd 8.1

Changed 8 years ago by Admin

Attachment: freebsd.patch added

Please check if the attached patch fixes your problem.

Changed 8 years ago by Admin

Attachment: freebsd2.patch added

Could also be that you need this one (sorry can't try myself as I don't have a Freebsd system)

comment:3 Changed 8 years ago by Admin

I included the second one in r5501. Please report back!

comment:4 in reply to:  3 Changed 8 years ago by ruggeroquargentan1

Replying to Admin:

I included the second one in r5501. Please report back!

problem solved
thanks

comment:5 Changed 8 years ago by alno

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.