Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#2026 closed defect (wontfix)

Blackout on some channels on CanalSat France SECA card

Reported by: miskiadesign Owned by:
Priority: major Component: Card support
Severity: medium Keywords: seca, france
Cc: sebastien.stormacq@… Sensitive: no

Description

Revision

5687

Issue Description

France 2 HD doesn't work anymore on CanalSat? France SECA cards
On the simple log we can see that the ECM is ok, and on the client side the "S" in infobar shows up green.

OSCam server side, MgCamd? client side, newcamd protocol = issue
OSCam full (server + dvbapi) = issue
CCcam = issue
Hypercam = issue

Note that the channel "Canal+ Family HD was blackout too this afternoon but working at this time... Strange.

In my debug 255 log the first channel is Canal+ HD => working
The second channel is Canal+ Family HD => working
The last ecms are on the France 2 HD channel => ISSUE

Thanks in advance to OSCam dev to have a look at my log to help the french community to use their card at 100%

When the issue occurs

Since this morning

How the issue is reproducable

By going on France 2 HD channel

Attachments (1)

csat_france_problem.txt (190.7 KB) - added by miskiadesign 9 years ago.
Debug 255 log

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by miskiadesign

Attachment: csat_france_problem.txt added

Debug 255 log

comment:1 Changed 9 years ago by miskiadesign

The channel wich are impacted: France 2 HD and SyFy? HD

comment:2 Changed 9 years ago by sebsto

Cc: sebastien.stormacq@… added

comment:3 Changed 9 years ago by littlejoe

Today 0500:003315:2265 : Canal+ Family HD impacted too.
Can we just detect the ECM difference (nano!?) and dont return CW?

comment:4 in reply to:  3 Changed 9 years ago by BurnMasterRecords

Replying to littlejoe:

Today 0500:003315:2265 : Canal+ Family HD impacted too.
Can we just detect the ECM difference (nano!?) and dont return CW?

U can try: Drop CWs with wrong checksum: in Reader Section.

comment:5 Changed 9 years ago by linux4sat

Paste from forum...

FR2 HD

80 00 61 33 11 01 07 5C 00 AC A8 D6 08 2D DD 47
07 73 53 1F 2D EA 76 CD 64 47 BC 5A 37 B3 50 5E
C6 74 27 54 F4 C0 17 8D 80 F2 36 ED B8 45 3A 3F
06 E5 1A 94 A8 9D 7B 88 E1 EE 07 C8 97 3D DD 99
AE EB 20 6B FD 3B 8E 85 15 0A E5 65 A2 8F E1 05
3C 1A 69 FD 41 0F 59 48 95 C4 25 C3 AA 87 F8 67

dcw D8 08 F4 8C B4 CF FB 3A 38 19 ED 56 E5 1B 4C B1

81 00 61 33 11 01 07 5C 00 C2 A8 45 5B 72 32 86
9A C0 D2 79 B8 C6 25 F1 0D A3 BB 26 E0 32 E4 10
BC 8D D4 06 2D BF 9D 72 93 A7 0D DE 99 62 78 61
CD 14 9C 66 52 C2 F9 3B 28 BD 5B B9 84 1B 12 AE
7E 87 53 72 70 BF 5A C5 49 99 74 D6 3C 32 71 71
DE ED 29 E7 1D 23 86 8F 43 1A B7 73 10 8F 54 3B
E2 48 43 FF

dcw D8 08 F4 8C B4 CF FB 3A AA 5D 4B 26 65 66 7D 4F

consécutive cw1 & cw2 ok juste le crc et dcw = bad

TF1 HD

81 00 61 33 11 00 07 5C 00 06 35 A6 61 AD 1E 23
1B EB 37 37 C7 D8 07 58 54 E5 1D 8B 38 DA 14 59
54 B1 F1 8D D2 00 40 C7 1A 21 C6 F3 5F 25 89 C5
09 08 86 8D 2E A8 96 F2 E8 8F 84 BA 97 24 8F 19
B0 DE A6 0F B2 5C D5 83 61 5D 61 6D 41 73 DD BC
1B BF F6 F4 0E 92 F6 19 D7 CB EA E7 CC C5 32 81
7D 91 16 A8

dcw E6 22 33 3B F0 48 69 A1 42 4B AE 3B F8 2B 97 BA

80 00 61 33 11 00 07 5C 00 5B 8A 6F 30 99 F0 1C
8C FE 4D 22 CD 40 FA DB DD 75 62 95 43 38 04 9D
77 9D 8F 2B 11 2A FA 0F A7 7E 51 4E 09 AD DA 98
E7 C2 EE 62 89 27 C1 EB 8B 77 AE 66 55 E2 48 F7
85 BF 69 E1 48 6E E9 7B 7C 19 93 45 AB 64 D2 49
9C 1D A0 D4 CA 23 21 83 9C 11 A4 7C D3 0A 93 EA
BD 80 39 51

dcw D2 9F 3F B0 FF 5E B7 14 42 4B AE 3B F8 2B 97 BA

Last edited 9 years ago by linux4sat (previous) (diff)

comment:6 Changed 9 years ago by sebsto

I tried using the "dropbadcw" option as described here
http://www.streamboard.tv/wiki/index.php/OSCam/en/Config/oscam.server#dropbadcws

It allows the server to return "Can not decode" and look for other cards. But it does not solve the original problem.

Last edited 9 years ago by sebsto (previous) (diff)

comment:7 Changed 9 years ago by sebsto

Problem is worst since 26 July : all CSAT / C+ HD channels are black now SECA : 0100:3315 and 100:3317.
I can provide log files as appropriate - I have some dev skills - no afraid to recompile - I am willing to help / test - just ask.

comment:8 Changed 8 years ago by yhzarcali

Is this issue ever going to be fixed? 9 months that's quite old already :(

comment:9 Changed 8 years ago by sebsto

workaround : ask for a second (standalone) card. CSat will ship you a VIAccess card which is working OK with OSCAM, including for HD channels

comment:10 in reply to:  9 Changed 8 years ago by yhzarcali

Replying to sebsto:

workaround : ask for a second (standalone) card. CSat will ship you a VIAccess card which is working OK with OSCAM, including for HD channels

I had a Viaccess card previously, CanalSAT fucked it up. It would be really preferable to fix this issue. As far as I can understand from the sources it is not a very big issue. Different nanos. But I am wondering what would be required to have it working again. Anyway, I am ready to give out as much help as possible.

comment:11 Changed 8 years ago by sebsto

+1
I have development / debugging skills in C / Python
I have a SECA and VIA card with official subscription.
I am ready to help - just waiting for instructions

comment:12 in reply to:  11 Changed 8 years ago by yhzarcali

Replying to sebsto:

+1
I have development / debugging skills in C / Python
I have a SECA and VIA card with official subscription.
I am ready to help - just waiting for instructions

I do as well, but my Viaccess card has been vanished from the CanalSAT database so I could not get it updated... And I am so tired of using their dirty 'Cube', I have never seen such a horrible device.

Last edited 8 years ago by yhzarcali (previous) (diff)

comment:13 Changed 8 years ago by yhzarcali

Btw sebsto, how did you manage to request a second card?

Last edited 8 years ago by yhzarcali (previous) (diff)

comment:14 Changed 8 years ago by sebsto

we should avoid using the bug tracking system as a discussion forum. That being said : I just asked a second card (stand alone card) to Canal. They send it by post and I activated following the instructions provided. See for more details http://www.oscam.to/wbb3/index.php?page=Thread&threadID=9036&highlight=

comment:15 Changed 8 years ago by avs1978

Component: GeneralCard support
Keywords: seca france added
Severity: Please fill inmedium

comment:16 Changed 7 years ago by fun7

Resolution: wontfix
Status: newclosed

If you can provide code for Seca Nano 01, that is used by CSAT provide a code or algo post it. Otherwise this gotta be closed because no fix possible.

Last edited 7 years ago by fun7 (previous) (diff)
Note: See TracTickets for help on using tickets.