Opened 8 years ago

Closed 8 years ago

#2187 closed defect (worksforme)

Compile error on x86_64 with WebIF enabled

Reported by: geek Owned by:
Priority: blocker Component: General
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

6014

Issue Description

./config.sh
Add-ons:

WEBIF : on
HAVE_DVBAPI : off
WITH_STAPI : off
IRDETO_GUESSING : off
CS_ANTICASC : off
WITH_DEBUG : off
CS_WITH_DOUBLECHECK : off
CS_LED : off
QBOXHD_LED : off
CS_LOGHISTORY : off
MODULE_MONITOR : off
WITH_SSL : on
WITH_SSLv3 : on
WITH_LB : on
LCDSUPPORT : off
IPV6SUPPORT : off

Protocols:

MODULE_CAMD33 : off
MODULE_CAMD35 : off
MODULE_CAMD35_TCP : off
MODULE_NEWCAMD : off
MODULE_CCCAM : on
MODULE_GBOX : off
MODULE_RADEGAST : off
MODULE_SERIAL : off
MODULE_CONSTCW : off
MODULE_PANDORA : off

Readers:

WITH_CARDREADER : off
READER_NAGRA : off
READER_IRDETO : off
READER_CONAX : off
READER_CRYPTOWORKS : off
READER_SECA : off
READER_VIACCESS : off
READER_VIDEOGUARD : off
READER_DRE : off
READER_TONGFANG : off

make

See attachment for error output

When the issue occurs

If You compile oscam with make on a x86_64 machine

How the issue is reproducable

If You compile oscam with make on a x86_64 machine

Attachments (1)

error.log (11.8 KB) - added by geek 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by geek

Attachment: error.log added

comment:1 Changed 8 years ago by cybero2912

cannot confirm
i386/x64 6014 compiling fine on ubuntu 10.10 using latest version of easy script

comment:2 Changed 8 years ago by Deas

check your openssl version and try to disable sslv3 support

comment:3 Changed 8 years ago by cybero2912

tried again with:
WITH_SSL : on
WITH_SSLv3 : on

edit: sorry what I worte before is wrong :(
when I enable SSL it is also not working here

Last edited 8 years ago by cybero2912 (previous) (diff)

comment:4 Changed 8 years ago by Deas

i mean that geek should check his versions and try to disable sslv3. but you could post your installed openssl version so he could check his version.

comment:5 Changed 8 years ago by geek

With disabled SSLv3 compiling is working.
libssl-dev version: 0.9.8g-15+lenny13

comment:6 Changed 8 years ago by Deas

Resolution: worksforme
Status: newclosed

did you build this version by yourself or is this a package you just downloaded? anyway - tis is not an oscam problem. please discuss this in the forum.

Note: See TracTickets for help on using tickets.