Opened 17 months ago

Closed 16 months ago

Last modified 16 months ago

#3316 closed task (fixed)

different ecm in one cycle canal digitaal and tvv

Reported by: harold Owned by:
Priority: Please fill in Component: Reader
Severity: low Keywords: rate limit cardlock
Cc: Sensitive: no

Description

Revision

al revision

Issue Description

freeze and finally locks the smarcard

When the issue occurs

by a canal digitaal smartcard

How the issue is reproducable

the canal digitaal cards locks by more than one ecm into one cycle
for 10 seconds.
Canal digitaal and Tvv used more or different ecm's into one cycle
and oscam don't reject the second ecm for same sid.
If i have 4 static sids into a service with rate limit 4 / 10
and one sid isn't yoused than there is a slot free for second ecm from same sid.
Finally if it happens too much the card locks by ecm limit from card.
Canal Digitaal and Tvv are use sid limit 4 sids in a 10 sec cycle
The future cw cycle check and ecm uniq don't clear the problem.

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Attachments (1)

ratelimit.patch (4.2 KB) - added by theparasol 17 months ago.
some fumbling with ratelimiter

Download all attachments as: .zip

Change History (15)

comment:1 Changed 17 months ago by Jan Gruuthuse

Take it up in the forum http://www.streamboard.tv . No support desk here. Clarify in the forum your question. What is your problem exactly. And detail your setup and usage. Now you tell something about the provider imposed limitations. Looks like usage/user configuration settings error to me.

comment:2 Changed 17 months ago by Jan Gruuthuse

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 17 months ago by harold

Its not a usage/user configuration settings error
Oscam doesn't see that there more or different ecm's are in one cycle
for one sid and finally the card locks because override the limit for one
ecm for one sid in 10 sec cycle
Canal digitaal used more or diff ecm's for one sid !
But thanks that you closed the ticket
The parasol now exactly what i mean and i had hope that he read this ticket no one else.
I thought he can made a function like one ecm for sid into a cyle a sort of ecm limiter
for a sid.
Or give the user the first cw from cache by diff ecm.
Because the cw is the same for minimal 10 sec.
If i set one sid in a service with rate limit 1 / 10 than i see in the logs
that the second ecm gets a reject by rate limit and no card lock happend.
By 4 sids and ratelimit 4 / 10 can more ecm for one sid ask the card for a cw and
locks the card.
Its a dutch problem and happens in alle cardserver software.

Greats


comment:4 Changed 17 months ago by theparasol

Perhaps this does something good?
Added an odd / even sequence filter and a md5 hash replacer on wrong ecm's

Last edited 17 months ago by theparasol (previous) (diff)

Changed 17 months ago by theparasol

some fumbling with ratelimiter

comment:5 Changed 17 months ago by harold

hello theparsol,

Thanks i will try the patch.

Greats

comment:6 Changed 17 months ago by harold

Hello again,

It looks this works great.

thanks en greats harold

comment:7 Changed 17 months ago by dr diq

If this works, theparasol is crowned to be THE hero of the YEAR! Big thanks!

comment:8 Changed 17 months ago by TGFS

  • Resolution invalid deleted
  • Status changed from closed to reopened

@Dr. TheParasol? can you make the patch in a build please, worksforme :) Thanks a lot!

Last edited 17 months ago by TGFS (previous) (diff)

comment:9 Changed 16 months ago by ni_hao

No need to ask such things in a ticket system. If you want to ask, use the appropriate thread in the forum. However, Did you try svn8643?

Last edited 16 months ago by ni_hao (previous) (diff)

comment:10 Changed 16 months ago by ni_hao

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 16 months ago by TGFS

Sorry ni_hao for this task, yes i did try OSCAM 1.20-unstable_svn build r8643. Anyway what's your question?

comment:12 Changed 16 months ago by BurnMasterRecords

Changeset 8643

Timestamp:05/13/13 01:33:28 (39 hours ago)
Author: theparasol
Message:•Enhanced the ratelimiter ecmunique with odd/even cycle check

Questions?

comment:13 Changed 16 months ago by TGFS

no, thanks a lot :)

comment:14 Changed 16 months ago by dr diq

@ theparasol

You indeed are THE hero of the YEAR!! Works SUPERB!!!!! Still No lock (Sometimes timeout so bit af a freeze caused by ECMUNIQUE, but the important thing, NO LOCK!

Thx again!

Note: See TracTickets for help on using tickets.