Opened 5 years ago

Last modified 5 years ago

#4200 new defect

CCcam cw crypt and MSG_NEW_CARD

Reported by: satguy Owned by:
Priority: major Component: Protocol - CCCam
Severity: high Keywords:
Cc: Sensitive: no

Description

Revision

<all version>

Issue Description

<Please fill in>

There is two issue. I am box' developer, so I can put the log code in OSCAM code.

  1. cc_cw_crypt(...) function bug

When send the CW to client, OSCAM encrypts the CW using this function, some times this function wrong.
This function shifts node_id for 4bits * i (nibble), after shift Noid_id, the upper nibble must be '0'.
but it is '1', so last byte of CW is wrong(upper nibble).


  1. MSG_NEW_CARD and MSG_NEW_CARD_SIDINFO

OSCAM server never give this msg even if connected the reader.
I tested using two OSCAM. one is server and other is client.

The sever is connected to other card reader, this server gets all card information.
But when the client connect this server, does not give any card information.
When try to connect about 50 times, the server give the card information.

When the issue occurs

<Please fill in>
It happened any times, when do something on 'Readers' and 'Users'.

How the issue is reproducable

<Please fill in>
It happened very frequently. when do something on 'Readers' and 'Users'.

<Don't forget to ATTACH (NOT post here as text) a log file of oscam in debug mode (start oscam with -d255) and to remove the brackets around the fields! Otherwise, your ticket will be closed as you seem to be unable to read.>

Attachments (1)

oscam_server_and_client.txt (10.6 KB) - added by satguy 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by satguy

Attachment: oscam_server_and_client.txt added

comment:1 Changed 5 years ago by Aeon

Can you give some examples for 1), please? (what the correct values is, and what oscam calculates).

About 2): maybe it works now with 10685?

Note: See TracTickets for help on using tickets.