Opened 4 years ago

Last modified 4 years ago

#4308 reopened defect

DVBAPI: the CW is decoded twice for the same channel

Reported by: TheTroll Owned by:
Priority: major Component: DVBApi
Severity: medium Keywords:
Cc: Sensitive: no

Description

Revision

10991

Issue Description

With DVBAPI, the CW is now decoded twice for the same channel

When the issue occurs

When a chan has 2 PROV ID that work, both are used indefinitely.

How the issue is reproducable

Try to decrypt RTS Un for instance

2015/09/13 14:57:37 2D7442C9 c (ecm) client (0500@023800/08E2/4333/2A:DD37D6607A): found ( 2 ms) by reader-1 (P/1/5/5) - RTS Un HD ()
2015/09/13 14:57:38 2D7442C9 c (ecm) client (0500@050800/08E2/4333/2A:FB0585CAAE): found ( 340 ms) by reader-2 (P/1/2/2) - RTS Un HD ()

Change History (19)

comment:1 Changed 4 years ago by TheTroll

Some more logs:

2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 ecmpid 0 CAID: 0500 ECM_PID: 02E3 PROVID: 050800
2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 ecmpid 1 CAID: 0500 ECM_PID: 02D9 PROVID: 040810
2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 ecmpid 2 CAID: 0500 ECM_PID: 02CF PROVID: 023800
2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 ecmpid 3 CAID: 0500 ECM_PID: 02ED PROVID: 060200
2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 found 4 ECMpids and 1 STREAMpids in PMT
2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 serving srvid 4333 (RTS Un HD ()) on adapter 0001 camask 0002 index 0000 pmtpid 0000
2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 trying to descramble PID 0 CAID 0500 PROVID 050800 ECMPID 02E3 ANY CHID PMTPID 0000 VPID 0017

...

then

2015/09/13 15:37:18 2D7442C9 c (dvbapi) Demuxer 1 trying to descramble PID 2 CAID 0500 PROVID 023800 ECMPID 02CF ANY CHID PMTPID 0000 VPID 0017

...

and then the log i gave in the report

comment:2 Changed 4 years ago by TheTroll

Important extra info: it only happens if we start decoding as there is already a chan being decoded using dvbapi.
If it's using Demuxer 0, so it's the first decoding, it does not use 2 PIDS.
If it's started first, even if a second decoding is done (using Demuxer 1 then), it works, no dual decoding...

comment:3 Changed 4 years ago by Jan Gruuthuse

Decoding 2 providers!
0500:023800
0500:050800
Perhaps you should take this 1st to the forum and discuss the issue there http://www.streamboard.tv/

comment:4 Changed 4 years ago by TheTroll

Yes but it's a bug, isnt it ?

comment:5 Changed 4 years ago by Jan Gruuthuse

Not certain: as far as OSCam is concerned it's a request for 2 different channels as the channel is asked for 2 different providers. or different cards for the same provider.
CAID:PROVID
0500:050800 SRF V5
0500:023800 SRF V2.6

You can have multiple providers on one channel if you get request for that channel for for provider A and then for provider B that is 2.
Most likely you have a wrongly configured client.
Don't use this tracking system for discussions, discuss in forum: http://www.streamboard.tv/

comment:6 Changed 4 years ago by Jan Gruuthuse

Priority: criticaltrivial
Resolution: invalid
Severity: highlow
Status: newclosed

comment:7 Changed 4 years ago by TheTroll

Priority: trivialmajor
Resolution: invalid
Severity: lowmedium
Status: closedreopened

Sorry but it is not a discussion !
This is clearly a bug, dvbapi should choose one of the 2 providers, not decode both obviously ...

This is a regression most probably due to recent commits

comment:8 Changed 4 years ago by Jan Gruuthuse

Resolution: invalid
Status: reopenedclosed

You should organise your settings and limit OSCam to one of the Provid and not offer both.
There are several possibilities for doing so.

comment:9 Changed 4 years ago by TheTroll

Resolution: invalid
Status: closedreopened

Come on, this is not the problem!
I really don't get why just ignore what I am saying ?

1- it worked before, it is due to new changes
2 -Unless you select the dvbapi option to try all CAIDs at the same time, which is not my case, it should not decode 2 ecms pids for the same channel request. And even if you set this option, it will try first all CAIDs and then use only one.

So please take some minutes to reconsider what I am saying instead of blindly sticking to your "check your conf" solution.

Last edited 4 years ago by TheTroll (previous) (diff)

comment:10 Changed 4 years ago by Jan Gruuthuse

Resolution: invalid
Status: reopenedclosed

You seem to be a very important person, not willing to use http://www.streamboard.tv/.
Your unknown box is requesting this channel. As you indicate. And for some reason it does so by using the other Provid
You only provide partial (very minimal) information.
Do as you please. I leave the fun to the developers.

comment:11 Changed 4 years ago by TheTroll

Resolution: invalid
Status: closedreopened

But the board is for dicussion, I am clearly reporting a bug with logs and descriptions...
I use the board when I need to discuss something, this is not the case here!

If you are not a developer, why are you commenting here ? Just leave the developers do it.
It really looks like you have no clue what you are talking about ...
"Your unknown box is requesting this channel. As you indicate. And for some reason it does so by using the other Provid"
=> it just proves that you did not understand a word from what I said... so yes, please leave it to other people.

comment:12 Changed 4 years ago by theparasol

Try r10995. Perhaps it is related to this lost running code

comment:13 Changed 4 years ago by theparasol

Nope, r10995: I was mistaken, no lost running code...

comment:14 Changed 4 years ago by TheTroll

Yep, bug fixed for me!

Thx a lot

comment:15 Changed 4 years ago by Poedel

Fixed by what? 10995 was reverted...

comment:16 Changed 4 years ago by TheTroll

I don't know, it works now.. i'll check why

comment:17 Changed 4 years ago by TheTroll

Ok I was too fast, it's not working ... I still get 2 requests at the same time:/

comment:19 Changed 4 years ago by TheTroll

Hi,

it's set to 0 = try all possible CAIDs one by one (default)

Note: See TracTickets for help on using tickets.