Opened 9 months ago

Closed 5 months ago

#4586 closed defect (fixed)

CA_SET_DESCR sent before CA_SET_DESCR_MODE in extended_cw mode.

Reported by: Joe User Owned by:
Priority: minor Component: DVBApi
Severity: low Keywords:
Cc: Sensitive: no

Description

Revision

11285

Issue Description

changeset 11285 (http://www.streamboard.tv/oscam/changeset/11285)
reverted changeset 11250 (http://www.streamboard.tv/oscam/changeset/11250/)

thereby causing CA_SET_DESCR to be again sent before CA_SET_DESCR_MODE in extended_cw mode.

I tracked this down to be the culprit of seemingly intermittent problems with Tvheadend (with my extended_cw fork - tvheadend does not yet support extended_cw) I have modified my code to ignore initial keys sent if the mode is not known yet. But this causes a little extra delay when starting channels. The better fix is to set the mode before sending keys (the logical sequence.)

Changeset 11285 references this thread http://www.streamboard.tv/wbb2/thread.php?postid=566744#post566744 but it is doubtful after reading the thread that this fixed anything. In fact it should have no affect since they are not using extended_cw. It is far more likely that their problem is related to what was fixed in changeset 11287 http://www.streamboard.tv/oscam/changeset/11287.

Also, this *may* be the cause of intermittent problems others have reported with enigma2 and extended_cw channels, but I have no way at the moment to test with enigma2...

When the issue occurs

On initial channel tune after restarting either Tvheadend or oscam.

How the issue is reproducable

Same as above, but you need my extended_cw fork of Tvheadend. :)

Attachments (1)

dvbapi_revert_11285.diff (1.8 KB) - added by Joe User 9 months ago.

Download all attachments as: .zip

Change History (3)

Changed 9 months ago by Joe User

Attachment: dvbapi_revert_11285.diff added

comment:1 Changed 9 months ago by pr2

I am testing since several days a version 11360 with this patch and so far no problem on my Solo4K so I agree with joeuser to revert change 11285 if this brings problem for extended_cw users.

comment:2 Changed 5 months ago by manio

Resolution: fixed
Status: newclosed

I believe we may now close this as it was merged by theparasol in r11385.

Note: See TracTickets for help on using tickets.