Opened 12 months ago

Closed 6 months ago

#4681 closed defect (invalid)

Build Error on x86_64 and others (libm not linked)

Reported by: caveman99 Owned by:
Priority: blocker Component: General
Severity: high Keywords: compiler error
Cc: Sensitive: no

Description

Revision

11429

Issue Description

The CAK7 Nagra Patch needs libm (math.h) on some systems, notably x86 amd other 'full linux' builds.

When the issue occurs

always

How the issue is reproducable

while building

Attachments (1)

MathLib.patch (558 bytes) - added by caveman99 12 months ago.
This patch adds -lm to the linker on systems that need it. CMAKE only.

Download all attachments as: .zip

Change History (2)

Changed 12 months ago by caveman99

Attachment: MathLib.patch added

This patch adds -lm to the linker on systems that need it. CMAKE only.

comment:1 Changed 6 months ago by Gorgone Impertinence

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.