Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#601 closed defect (fixed)

new card activation for dre crypt

Reported by: and Owned by:
Priority: major Component: Reader
Severity: medium Keywords:
Cc: Sensitive: no

Description

pathc for reader-dre.c (version oscam v0.99.4svn, build #2213)

362a363,374
>     if(ep->type == UNIQUE && ep->emm[39] == 0x3d)
>     { /* For new package activation. */
>         static uchar emmcmd58[26];
>         emmcmd58[0] = 0x58;
>         memcpy(&emmcmd58[1], &ep->emm[40], 24);
>         emmcmd58[25] = 0x15;
>         if ((dre_cmd (emmcmd58)))
>             if ((cta_res[cta_lr - 2] != 0x90) || (cta_res[cta_lr - 1] != 0x00))
>                 return ERROR;
>     }
>     else
>     {
375a388
>     }

Attachments (1)

reader-dre.c (14.5 KB) - added by and 9 years ago.
reader-dre with patch

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by Point

2 and
send me please full version reader-dre.c include patch

Changed 9 years ago by and

Attachment: reader-dre.c added

reader-dre with patch

comment:2 Changed 9 years ago by Point

ok activation & AU chip DRE2 from GS7300

comment:3 Changed 9 years ago by merek

Resolution: fixed
Status: newclosed

comment:4 Changed 9 years ago by yuriks

replace line
emmcmd58[25] = 0x15;
with
emmcmd58[25] = reader->provider;

Note: See TracTickets for help on using tickets.